Disabling allowed protocols

Dec 1, 2016 at 10:35 AM
Edited Dec 1, 2016 at 10:35 AM
Hi,

I am using Windows 10 and I have successfully created vpns with DotRas. The only problem is that I can't understand how to uncheck any of allowed protocols (Chap and Mschapv2 are selected by default) in the Security tab of vpn options (see picture below). I tried with VpnEntry.Options.RequireChap=false property, however Chap remains selected with Mschapv2. Is there a way to do this or is this just an issue of Windows 10 ?

Image
Coordinator
Feb 4 at 11:52 AM
That was always one of the worst parts of the RAS API Microsoft exposes. Most of what I do ends up being trial and error to see what combination of settings makes it look like I need to get it to work.
Editor
Feb 21 at 2:24 PM
Yeah, there's a severe mismatch sometimes between API names and UI names and no clear place to find mappings between them.