Having Problem building the project

Jun 28, 2010 at 2:52 PM

Hi, Thanks for this awsome project Jeff. It makes life a lot easier.

I am having a little problem here though. Well, I am not too good at using command prompt and that might be the reason. I tried building the project following the instructions in the documentation and here's where I got stuck after running the make.bat file and choosing option 1:

MSBUILD : error MSB1009 : Project file does not exist.

Switch : .\build.proj

How do I get pass this please? I am using Visual Studio 2010 command prompt and the 59933 (v1.1) release. The bin folder contains only the WIN2K dll and I could not find the CreateBroadbandEntry method and the PPPoE device type in it. Any assistance will be appreciated please.

Thanks.

Coordinator
Jun 28, 2010 at 9:36 PM

The only reason it would not be able to find the build.proj file is if it was missing from the folder where the batch file was located. It's a relative path so they need to be sitting next to each other. Along with being next to each other, they need to be in the expected location since the paths in the build.proj file expect it to be where I have it sitting.

The output bin folder would not have been generated because the build.proj file was not found. I'm guessing you looked in the Examples\Bin folder and found the WIN2K.dll that was sitting in there and thought it might be what you were looking for. That DLL is only there as a reference for the example projects so when they're installed you don't get any missing reference exceptions when opening the examples. It's also replaced when the examples are being built to ensure each of them compiles correctly.

The build output would be located in Output\Bin as indicated by the compilation documentation page.

Jun 29, 2010 at 12:46 PM

Apparently, there is a file named build.proj in the same directory as the make.bat. They are both in the Trunk folder along with five other folders: Components, Examples, Help, Media and Source. Is there anything I need to change in the name.bat file? Or better yet, Is there a place I can get the compiled dll files for Windows 7, Vista and XP? I have urgent need for this and would appreciate any help.

Thanks.

Coordinator
Jun 29, 2010 at 2:19 PM

That's all that's needed for the compilation system to work, everything sounds to be in the proper location. The settings that need to be changed are set in that batch file that then call the build.proj file which handles the actual compilation. Any applications that are not installed have their parts of the build process skipped (WiX for installation packages, Sandcastle or Sandcastle Help File Builder for the help documentation, etc). However, if it can't find the build.proj file it wouldn't even get to that point.

You can always build it manually in Release configuration for Any CPU. The compilation symbols you pass to the project determine which version is built. Just pass the WINXP symbol in the Build properties for the project and it should compile just fine.

Jul 2, 2010 at 5:47 PM

Hello Jeff! Thanks for your time. I finally figured it out. I was running the make.bat file with it's full name (C:\...\make.bat) instead of first changing to the directory and running make.bat. Something else came up though. It was looking for "C:\Program Files\MSBuild\Microsoft\StyleCop\v4.3\Microsoft.StyleCop.targets" which was not on my system. I even tried to load the project in visual studio to build it manually as you suggested but to no avail.

Eventually, I hacked the source. I openned the C# project file with notepad and saw this: <Import Project="$(MSBuildExtensionsPath)\Microsoft\StyleCop\v4.3\Microsoft.StyleCop.targets" />. I commented it out <!-- <Import Project="$(MSBuildExtensionsPath)\Microsoft\StyleCop\v4.3\Microsoft.StyleCop.targets /> --> and was able to build it from the command prompt as well as load it with visual studio 2010.

Does that have any effect on the output? I am already using it and have not noticed anything but I would like to be sure please.

Thanks.

Coordinator
Jul 2, 2010 at 7:29 PM
Edited Jul 2, 2010 at 7:31 PM

No, it doesn't have any effect. Microsoft StyleCop is a source analysis tool that analyzes the formatting of C# code. The line you commented simply turned it off.

Edit: Here's a link to it if you're curious... http://stylecop.codeplex.com/

Jul 3, 2010 at 8:44 AM

Thanks man! You are great!

Aug 24, 2010 at 7:24 AM

Hi Jeff,

I have similar errors as well, except that I am using VB and visual studio 2010. I wondering if anyone have similar errors to me. I have gone through the whole discussion forum and this is the closes that I can get.  I have added reference to the DotRas.dll and have also got the tools to show at the toolbox. Drag and drop everything and using the class or workspace from DotRas looks well, but when compilation comes it always says <error BC30002: Type 'DotRas.xxx' is not defined>. I am not really sure which part of the instruction did i went wrong. Could you be so kind to help me out? really appeciate it.

Thanks in advance.

Aug 24, 2010 at 9:12 AM

HI Jeff,

I found the error. The error was cause by the wrong selection of CPU which should be any and the incorrect compilation which by default was using .net 4.0 but it should be .net 2.0. :)

 

Coordinator
Aug 24, 2010 at 1:49 PM
Edited Aug 24, 2010 at 1:49 PM

Glad to hear you got the problem fixed. Is there anything you feel I should add to the documentation page to keep others from having the same problems you experienced?