RasPhoneBook problems

Feb 23, 2010 at 2:15 PM

Hi Jeff,

compliments for your great job.

I've same problems with RasPhoneBook class, DotRas version 1.1. I don't use the Open method mode, because it's exception anyway.

I've tried with your suggestions founds to discussions section, but it continues not to work.  I've tried to download the last version 55934, but when I compile it this error

DotRas Release Builder
Copyright (c) Jeff Winn. All rights reserved.

The system cannot find the file specified.
*******************************************
* ABORTING! MISSING SNK FILE
*******************************************

Aborting the build process. The private key could not be found.
Please make sure the USB key is inserted in the machine or edit
this file and change the path to the key file.

KEYFILE: E:\Private Keys\JeffWinn.snk

 

Have you some solutions?

Thanks

Corrado

Coordinator
Feb 23, 2010 at 11:02 PM
Edited Feb 23, 2010 at 11:07 PM

That's just because the release building system uses a private strong key file I have here that I don't have stored in source control. This allows others to build the project without claiming it came from me. You just need to edit the make.bat file and modify where SET KEYFILE is defined and change the value to ".\DotRas\DotRas\Public.snk" which is included with the project or any other strong name key file you may wish to use (relative or fully qualified paths will work).

You may also need to edit the make.bat file to turn off any thing you don't want it to do during the build process. I probably have programs installed on my machine you'd be missing. You'll need to set those booleans to "False". The area you're able to edit without breaking the batch file is commented and located right at the start of the file and each value is documented. Any text editor can be used to modify the file.

Edit: I thought I'd mention, you can use the RasPhoneBook in v1.1 you just need to make sure the directory exists where you're opening the phone book before you open it. If the machine has never had any phone books previously defined in Windows the directory doesn't exist which causes that exception to be thrown.

- Jeff

Feb 24, 2010 at 1:11 PM

Ok.

Rebuild it's done. The exceptions problem are fixed.

Thanks

Corrado